tomcat

idea环境下

  1. tomcat版本引发的问题 系统还原后,启动idea使用tomcat 7.0.92版本启动springMVC项目,后台报错,且是web.xml文件有错;或者使用tomcat 9.0.14版本,后台无任何报错,且能打开首页;但是请求url如“***/one/first.action,则前端500,如图:

这是因为将错误版本tomcat下的lib中的el复制进了jdk目录下的lib/ext中;解决办法是删除即可。(这是在开发ehr系统时放进去的)。 还要注意是否将tomcat目录下的lib中的jsp-api和servlet-api放进了jdk目录下的lib/ext中(也是在开发ehr系统时放进去的)。

  1. idea配置